Support Center

What are the system requirements for Flume New Tab?

Last Updated: Jun 10, 2016 11:21AM CEST
Safari 8+ or Chrome 44+ is required to make use of Flume New Tab.

Contact Us

be782a53df760cacec70265688a442df@flume.desk-mail.com
http://assets2.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete